Overview

  • DM50F is a High-Speed USB programmer produced by CORIGHT.
  • DM50F support 25 FLASH, 24 EEPROM, 25 EEPROM, 93 EEPROM, etc.
  • DM50F support rolling code chip(HCS series).
  • DM50F Safe, High-Speed, Portable.

[Features]
[System Requirements]
[End-user license agreement]

Copyright © 2010-2012 CORIGHT.COM All rights reserved.


User Interface

DM50F has friendly user interface, menus, toolbars, concise and easy to use, the software interface is as follows:

DM50F toolbar:

  • Open: Load a file into the buffer.
  • Save: Save the buffer to a file.
  • Fill: Fill the specified buffer data segment for a specified value.
  • Swap: Swap two adjacent bytes.
  • Auto: Automatically complete the programming operation.
  • Erase: Erase chip data (set to 1).
  • Write: Write the data in buffer into the chip.
  • Read: Read the chip data into the buffer.
  • Verify: Compare the data in buffer with the data in chip.
  • Pinout: View the current chip pin configuration.
  • Device: Check the equipment model and version information.
  • About: Displays program information, version number and copyrightabout.


Automatic Programming

  • Auto complete "erase", "write", "check", "read" combined operations.
  • Specific combination of operations can be modified through the "Options".


Erase

  • Erase chip data (set to 1).
  • Some SPI FLASH chip must be erased before writing data operation.
  • When some chip does not support the erase operation is selected, the "erase" option will be disabled.


Fill

Interface:

  • Fill the specified buffer data segment for a specified value.
  • Automatic computing start address and length of the buffer to be filled.
  • Did not select any data: address is set to 0, the length is equal to the length of the buffer.
  • If you have selected data: address is set to the selected data starting position, the length is equal to the selected data length.


Location

Interface:

  • Target Address：The position want to go.
  • Current Address：Current position.
  • Click on the button "Go" to jump to the target address.
  • Click on the button "Cancel" to quit.


Mass Production

Interface:

  • Each computer can be connected to an unlimited number of devices (only the first 16 devices will show progress and status).
  • The equipment does not interfere with each other (replace chip or plug devices or remove devices at any time is permitted).
  • Automatically detects whether the chip is ready and enter the programming mode(perform automatic programming of setting).
  • Exit this window to exit the production mode (all equipment in a ready state required).


Read

  • Read the chip data into the buffer.
  • When some of the chip (HCS series) does not support read operation is selected, "read" option will be disabled.


Self Check

  • Check if there is hardware failure or not.
  • Please remove the chip before self-checking, otherwise will be prompted to self-test failure.


Verify

  • Compare the data in buffer with the data in chip.
  • When some chips (HCS series) which do not support checking operation is selected, the "check" option will be disabled.


Write

  • Write the data in buffer into the chip.
  • Some SPI FLASH chip must be erased before writing data operation.


Check For Updates

Check the software update:

  • Select "Check For Software";
  • Click on the "check update", follow the prompts and complete the operation.

Check the firmware update:

  • Select "Check For Firmware";
  • Click on the "Check For Updates", follow the prompts and download the latest firmware file to local disk.
  • Upgrade equipment through "Update Firmware".


Language Setting

  • EP01 support multilingual language (up to 1000 countries).
  • EP01 provide "English", "Simplified Chinese", "Traditional Chinese" three languages as default.
  • Modify or add any language according to need.

Modify Language:

  • Open the language file in the folder "Language".
  • Modify the text.
  • Save and restart EP01 software.

Add Language:

  • Enter the "Language" folder.
  • Copy any existing language file as a new one.
  • Edit the new language file.
  • Set the string "Language" in section "[Setting]" to a new value (show as new language name).


Options

Automatic Programming:

  • Through the "add", "delete", "empty" operation and mouse click to edit the content of "Automatic Programming".
  • Repeat operation support.

Editor:

  • Columns: The columns of the data.
  • Sections: The sections numbers of the data in a line.
  • Show Address: Whether to display the data address.
  • Data: Data display mode.
  • Show ASCII: Whether to display character area.
  • Show UNICODE: Whether to show the UNICODE character (available only when "Show ASCII" is checked).
  • Fore Color: The font color of each region.
  • Back Color: The background color of each area.
  • Default: Restore the Settings on this page to default values.


Pinout

Interface:

  • View the pin configuration of current chip.
  • Recommend to check the pin configuration before replacing chips, to avoid operation fails.


Rolling Code

Interface:

  • According to different choice chip set interface will change.
  • Support for all four encoding style: Simple, Normal, Secure XOR, Secure the Decrypt.
  • All 24 bytes of data can be modified to meet all requirements.
  • Rolling code chip is a "write-only" chip, so EP01 provide only "written" function.
  • Check operation followed by writing data immediately, and the results are given.


Update Firmware

  • Get the latest firmware through "Check Update" opreation.
  • Click the menu "Help"->"Update Firmware".
  • Select the latest firmware file, follow the prompts and complete the operation.


Contact Us

If you encounter problems in using or you have any good Suggestions to the software, please contact us through the following way:

By E-mail:


FAQ

1.Write data failure
(1)Check the chip and pin configuration before writing operation.
(2)Some SPI FLASH chips must be erased before writing operation.
(3)Memory chips might have been damaged.
(4)Programmer is faulty,Update the latest software and firmware.


Chip List

*************************Rolling code chip***************************
MICROCHIP：HCS101; HCS200; HCS201; HCS300; HCS301;

*************************24 EEPROM***************************
ATMEL：AT24C01; AT24C01A; AT24C01B; AT24C02; AT24C02A; AT24C02B; AT24C04; AT24C04A; AT24C04B; AT24C08; AT24C08A; AT24C08B; AT24C16; AT24C16A; AT24C16B; AT24C32; AT24C32A; AT24C32B; AT24C64; AT24C64A; AT24C64B; AT24C128; AT24C128A; AT24C128B; AT24C256; AT24C256A; AT24C256B; AT24C512; AT24C512A; AT24C512B; AT24C1024; AT24C1024A; AT24C1024B;
CATALYST：CAT24C01; CAT24C02; CAT24C04; CAT24C08; CAT24C16; CAT24C32; CAT24C64; CAT24C128; CAT24C256; CAT24C512; CAT24C1024;
FAIRCHILD：FM24C01; FM24C02; FM24C03; FM24C04; FM24C05; FM24C08; FM24C09; FM24C16; FM24C17; FM24C32; FM24C64; FM24C128; FM24C256; FM24C512; FM24C1024;
HOLTEK：HT24C01; HT24LC01; HT24C02; HT24LC02; HT24C04; HT24LC04; HT24C08; HT24LC08; HT24C16; HT24LC16; HT24C32; HT24LC32; HT24C64; HT24LC64; HT24C128; HT24LC128; HT24C256; HT24LC256; HT24C512; HT24C1024;
ISSI：IS24C01; IS24C02; IS24C04; IS24C08; IS24C16; IS24C32; IS24C64; IS24C128; IS24C256; IS24C512; IS24C1024;
MICROCHIP：24AA00; 24LC00; 24FC00; 24AA01; 24LC01; 24FC01; 24AA02; 24LC02; 24FC02; 24AA04; 24LC04; 24FC04; 24AA08; 24LC08; 24FC08; 24AA16; 24LC16; 24FC16; 24AA32; 24LC32; 24FC32; 24AA64; 24LC64; 24FC64; 24AA128; 24LC128; 24FC128; 24AA256; 24LC256; 24FC256; 24AA512; 24LC512; 24FC512; 24AA1026; 24LC1026; 24FC1026;
NSC：24C02; 24C02L; 24C64;
NXP：PCA24S08A;
RAMTRON：FM24C04A; FM24CL04; FM24C16A; FM24CL16; FM24C64; FM24CL64; FM24C256; FM24CL256; FM24C512;
ROHM：BR24C01; BR24L01; BR24C02; BR24L02; BR24C04; BR24L04; BR24C08; BR24L08; BR24C16; BR24L16; BR24C32; BR24L32; BR24C64; BR24L64;
ST：ST24C01; ST24C02; ST24C04; ST24C08; ST24C16; ST24C32; ST24C64;
XICOR：ST24C01; ST24C02; ST24C04; ST24C08; ST24C16;

*************************25 EEPROM***************************
ATMEL：AT25010; AT25020; AT25040; AT25080; AT25160; AT25320; AT25640; AT25128; AT25256; AT25512;
CATALYST：CAT25C01; CAT25C01P; CAT25C01S; CAT25C01U; CAT25C02P; CAT25C02S; CAT25C02U; CAT25C03P; CAT25C03S; CAT25C03U; CAT25C04P; CAT25C04S; CAT25C04U; CAT25C05P; CAT25C05S; CAT25C05U; CAT25C08P; CAT25C08S; CAT25C08U; CAT25C09P; CAT25C09S; CAT25C09U; CAT25C16P; CAT25C16S; CAT25C16U; CAT25C17P; CAT25C17S; CAT25C17U; CAT25C32P; CAT25C32S; CAT25C33P; CAT25C33S; CAT25C64P; CAT25C64S; CAT25C65P; CAT25C65S; CAT25C128P; CAT25C128S; CAT25C256P; CAT25C256S;
MICROCHIP：25C040; 25C080; 25C160; 25C320; 25C640; 25LC040; 25LC080; 25LC160; 25LC320; 25LC640; 25LC128; 25AA040; 25AA080; 25AA160; 25AA320; 25AA640; 25AA128;
RAMTRON：FM25C160; FM25640; FM25CL64;
ST：ST25C01; ST25C02; ST25C04; ST25C08; ST25C16; ST25W01; ST25W02; ST25W04; ST25W08; ST25W16; M95010; M95020; M95040; M95080; M95160; M95320; M95640; M95128; M95256; M95512;
TI：TI2532; TI2532A; TI2564;
XICOR：XC25010; XC25020; XC25040; XC25080; XC25160; XC25320; XC25640; XC25128; XC25256; XC25512;

*************************93 EEPROM***************************
ACE：ACE93C46-16bit; ACE93C46-8bit;
AKM：AK93C45A; AK93C55A; AK93C65A; AK93C75A;
ATC：ATC93C46-16bit; ATC93C46-8bit; ATC93C56-16bit; ATC93C56-8bit; ATC93C66-16bit; ATC93C66-8bit; ATC93C86-16bit; ATC93C86-8bit;
ATMEL：93C46-16bit; 93C46-8bit; 93C56-16bit; 93C56-8bit; 93C66-16bit; 93C66-8bit; 93C76-16bit; 93C76-8bit; 93C86-16bit; 93C86-8bit;
CATALYST：CAT93C46-16bit; CAT93C46-8bit; CAT93C56-16bit; CAT93C56-8bit; CAT93C57-16bit; CAT93C57-8bit; CAT93C66-16bit; CAT93C66-8bit; CAT93C86-16bit; CAT93C86-8bit;
EXEL：XL93C06; XL93C46; XL93CS46; XL93LC46; XL93C56; XL93LC56; XL93C66; XL93LC66;
FAIRCHILD：FM93C06; FM93C46; FM93C46A-16bit; FM93C46A-8bit; FM93C56; FM93C56A-16bit; FM93C56A-8bit; FM93C66; FM93C66A-16bit; FM93C66A-8bit; FM93C86A-16bit; FM93C86A-8bit;
HOLTEK：HT93LC46-16bit; HT93LC46-8bit; HT93LC56-16bit; HT93LC56-8bit; HT93LC66-16bit; HT93LC66-8bit;
ICT：ICT93C46-16bit; ICT93C46-8bit; ICT93C56-16bit; ICT93C56-8bit; ICT93C66-16bit; ICT93C66-8bit;
ISSI：IS93C46; IS93C46A-16bit; IS93C46A-8bit; IS93C56; IS93C56A-16bit; IS93C56A-8bit; IS93C66; IS93C66A-16bit; IS93C66A-8bit; IS93C76A-16bit; IS93C76A-8bit; IS93C86A-16bit; IS93C86A-8bit;
MICROCHIP：93C06; 93C46-16bit; 93C46-8bit; 93C56-16bit; 93C56-8bit; 93C66-16bit; 93C66-8bit; 93C76-16bit; 93C76-8bit; 93C86-16bit; 93C86-8bit; 93C46B; 93C46A; 93C56B; 93C56A; 93C66B; 93C66A; 93LC46-16bit; 93LC46-8bit; 93LC56-16bit; 93LC56-8bit; 93LC66-16bit; 93LC66-8bit; 93LC76-16bit; 93LC76-8bit; 93LC86-16bit; 93LC86-8bit; 93LC46B; 93LC46A; 93LC56B; 93LC56A; 93LC66B; 93LC66A; 93AA46-16bit; 93AA46-8bit; 93AA56-16bit; 93AA56-8bit; 93AA66-16bit; 93AA66-8bit; 93AA76-16bit; 93AA76-8bit; 93AA86-16bit; 93AA86-8bit;
NSC：93C06; 93C46; 93C56; 93C66; 93C86; 93CS06; 93CS46; 93CS56; 93CS66; 93CS86;
ROHM：BR93LC46; BR93LC56; BR93LC66; BR93LC46RF; BR93LC56RF; BR93LC66RF;
SEIKO：S-93C46A; S-93C56A; S-93C66A;
ST：ST93C06; ST93C46; ST93C56; ST93C66; M93S46; M93S56; M93S66; M93S46R; M93S56R; M93S66R; M93S46W; M93S56W; M93S66W;

*************************SPI FLASH***************************
ALTERA：EPCS1; EPCS4; EPCS16; EPCS64;
AMIC：A25L512; A25L010; A25L020; A25L040; A25L080; A25L016; A25L032; A25L05PT; A25L05PU; A25L10PT; A25L10PU; A25L20PT; A25L20PU; A25L40P; A25L80P; A25L16PT; A25L16PU;
ATMEL：AT25F512; AT25F512A; AT25F512B; AT25F1024; AT25F1024A; AT25F2048; AT25F4096; AT25FS010; AT25FS020; AT25FS040; AT26F004; AT25DF021; AT25DF041A; AT26DF081A; AT25DF161; AT26DF161; AT26DF161A; AT25DF321; AT25DF321A; AT26DF321; AT25DF641;
EON：EN25P05; EN25B05; EN25B05T; EN25P10; EN25B10; EN25B10T; EN25P20; EN25B20; EN25B20T; EN25P40; EN25B40; EN25B40T; EN25P80; EN25B80; EN25B80T; EN25P16; EN25B16; EN25B16T; EN25P32; EN25B32; EN25B32T; EN25P64; EN25B64; EN25B64T; EN25F05; EN25LF05; EN25F10; EN25LF10; EN25F20; EN25LF20; EN25F40; EN25LF40; EN25F80; EN25F16; EN25F32; EN25F64; EN25F128; EN25Q80A; EN25Q16; EN25Q16A; EN25Q32A; EN25Q32B; EN25Q64; EN25Q128; EN25D10; EN25D20; EN25D40; EN25D80; EN25D16; EN25T80; EN25T16;
EXCELSEMI：ES25P10; ES25P20; ES25P40; ES25P80; ES25P16; ES25P32; ES25M40; ES25M40A; ES25M80; ES25M80A; ES25M16; ES25M16A;
ESMT：F25L004A; F25L004AT; F25L04UA; F25L008A; F25L008AT; F25L08PA; F25L016A; F25L016AT; F25L16PA; F25L32PA; F25L32QA;
MICRON：N25Q128A; N25Q256A;
MXIC：MX25L512; MX25V512; MX25L1005; MX25L2005; MX25L4005A; MX25V4005; MX25L8005; MX25V8005; MX25L1605D; MX25L1606E; MX25L1635D; MX25L3205D; MX25L3206E; MX25L3225D; MX25L3235D; MX25L3237D; MX25L6405D; MX25L6406E; MX25L12805D; MX25V4035; MX25V8035;
NEXFLASH：NX25P10; NX25P20; NX25P40; NX25P80; NX25P16; NX25P32;
PMC：PM25LV512; PM25LV010; PM25LV020; PM25LV040; PM25LV080B; PM25LV016B;
SAIFUN：SA25F005; SA25F010; SA25F020; SA25F040; SA25F080; SA25F160; SA25F320;
SPANSION：S25FL004A; S25FL008A; S25FL016A; S25FL032A; S25FL064A; S25FL128S; S25FL256S; S25FL512S;
SST：SSST25VF512; SSST25VF512A; SSST25VF010; SSST25VF010A; SSST25VF020; SSST25VF020A; SSST25VF040; SSST25VF040A; SSST25VF040B; SSST25VF080B; SSST25VF016B; SSST25VF032B; SSST25VF064C;
ST：M25P05; M25P10; M25P20; M25P40; M25P80; M25P16; M25P32; M25P64; M25P128; M25P05A; M25P10A; M25PE10; M25PE20; M25PE40; M25PE80; M25PE16; M25PX80; M25PX16; M25PX32; M25PX64;
WINBOND：W25P10; W25X10; W25X10A; W25X10AL; W25X10L; W25P20; W25X20; W25X20A; W25X20AL; W25X20L; W25P40; W25X40; W25X40A; W25X40AL; W25X40L; W25P80; W25X80; W25X80A; W25X80AL; W25X80L; W25P16; W25X16; W25P32; W25X32; W25X64; W25Q20; W25Q40; W25Q80; W25Q16; W25Q32; W25Q64; W25Q128; W25Q256;


End-user license agreement

IMPORTANT-READ CAREFULLY:
This End-User License Agreement is a legal agreement between you (either an individual or a single entity) and CORIGHT for the software product identified above, which includes computer software and may include associated media, printed materials, and "online" or electronic documentation ("SOFTWARE PRODUCT"). By installing, copying, or otherwise using the SOFTWARE PRODUCT, you agree to be bound by the terms of this LICENSE AGREEMENT.
If you do not agree to the terms of this LICENSE AGREEMENT, do not install or use the SOFTWARE PRODUCT. Please do NOT order a registration key, if you do not agree to this license agreement.

License conditions

No part of the software or the manual may be multiplied, disseminated or processed in any way without the written consent of CORIGHT. Violations of these conditions will be prosecuted in every case.

The use of the software is done at your own risk. The manufacturer and developer accepts no liability for any damages, either as direct or indirect consequence of the use of this product or software.

Only observance of these conditions allows you to use the hardware and software in your computer system.

All rights reserved.
Copyright 2010-2012 CORIGHT.

SOFTWARE PRODUCT LICENSE

The SOFTWARE PRODUCT is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties. The SOFTWARE PRODUCT is licensed, not sold. This also applies to demo versions.

GRANT OF LICENSE. This LICENSE AGREEMENT grants you the following rights:

Applications Software.
You may install and use one copy of the SOFTWARE PRODUCT, or any prior version for the same operating system, on a single computer. The primary user of the computer on which the SOFTWARE PRODUCT is installed may make a second copy for his or her exclusive use.

Storage/Network Use.
You may also store or install a copy of the SOFTWARE PRODUCT on a storage device, such as a network server, used only to install or run the SOFTWARE PRODUCT on your other computers over an internal network; however, you must acquire and dedicate a license for each separate computer on which the SOFTWARE PRODUCT is installed or run from the storage device. A license for the SOFTWARE PRODUCT may not be shared or used concurrently on different computers.

OEM License.
If you obtained this license agreement together with a hardware product, you are allowed to use this SOFTWARE PRODUCT as a part of the Hard- and Software package according to this license agreement.

DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS.

Demo Version.
Even if the SOFTWARE PRODUCT is a demonstration version, it is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties.

Limitations on Reverse Engineering, Decompilation, and Disassembly. You may not reverse engineer, decompile, or disassemble the SOFTWARE PRODUCT, except and only to the extent that such activity is expressly permitted by applicable law notwithstanding this limitation. This also applies to Demo versions.

Separation of Components.
The SOFTWARE PRODUCT is licensed as a single product. Its component parts may not be separated for use on more than one computer. This also applies to Demo versions.

Rental.
You may not rent, lease, or lend the SOFTWARE PRODUCT. This also applies to Demo versions.

Software Transfer.
You may not transfer the SOFTWARE to another individual or organization. There are absolutely no exceptions.

Termination.
The license to use the SOFTWARE PRODUCT ends at the 31st of December, 2100.
The license to use the SOFTWARE PRODUCE ends, if you pass your personal registration key to another individual or organization.
Without prejudice to any other rights, CORIGHT may terminate this LICENSE AGREEMENT if you fail to comply with the terms and conditions of this LICENSE AGREEMENT. In such event, you must destroy all copies of the SOFTWARE PRODUCT and all of its component parts.

UPGRADES.
If the SOFTWARE PRODUCT is labeled as an upgrade, you must be properly licensed to use a product identified by CORIGHT as being eligible for the upgrade in order to use the SOFTWARE PRODUCT.
A SOFTWARE PRODUCT labeled as an upgrade replaces and/or supplements the product that formed the basis for your eligibility for the upgrade. You may use the resulting upgraded product only in accordance with the terms of this LICENSE AGREEMENT. If the SOFTWARE PRODUCT is an upgrade of a component of a package of software programs that you licensed as a single product, the SOFTWARE PRODUCT may be used and transferred only as part of that single product package and may not be separated for use on more than one computer.

END of document


Features

  • Compactness and portability.
  • Built-in self recovery fuse to provide ongoing protection of equipment.
  • USB 2.0 interface, the speed is up to 12Mbps.
  • Support rolling code chip(HCS series).
  • Support 25 FLASH, 24 EEPROM, 25 EEPROM, 93 EEPROM, etc.
  • Auto detect chip modles.
  • Software and firmware upgrades automatically.
  • Support for multiple languages, modify or add any language.
  • Friendly buffer edit window.
  • Support for Windows 2000、Windows XP、Windows Vista、Windows 7、Windows 8。

[Overview]


System Requirements

Minimum System Requirements:

  • Operating system: Win2000/XP/Vista/WIN7(32bit 64bit)/WIN8。
  • Resolution: 1024*768。
  • USB1.0 standard of universal serial bus (usb) interface.
  • A cd-rom drive.
  • 64M of RAM.
  • At least 10M hard disk space.

[Overview]